您现在的位置: 首页 > 微信营销 > 配资排名 > 源码交易, 交易指标源码

源码交易, 交易指标源码

作者:   来源:  热度:44  时间:2020-06-10







1、普通跟随画线源码SM1:SMA(C,N1,N2);A:=SM1>REF(SM1,1

1、普通跟随画线源码

SM1:SMA(C,N1,N2);

A:=SM1>REF(SM1,1); B:=SM1

A1:=BARSLAST(A)

DRAWCOLORLINE(REFX(A1,1),SM1,COLORRED,COLORGREEN),LINETHICK3;

 

 

 2、 MACD系统指标源码

 

 

DIFF: EMA(CLOSE,SHORT) - EMA(CLOSE,LONG);

DEA  : EMA(DIFF,M);

2*(DIFF-DEA),COLORSTICK;

 

 3、求一段MACD数值之和源码

 

 

求一段MACD之和代码第一种表达形式:DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);DEA:EMA(DIFF,9);MACD:2*(DIFF-DEA),COLORSTICK;JC:=CROSS(DIFF,DEA);SC:=CROSSDOWN(DIFF,DEA);MM:=VALUEWHEN(SC,REF(SUM(MACD,BARSLAST(JC)+1),1));//金叉开始到死叉MACD和DRAWNUMBER1(SC,MACD,MM,2);DRAWNUMBER1(JC,MACD,REF(SUM(MACD,BARSLAST(SC)+1),1),2); 第二种表达形式:DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);DEA:EMA(DIFF,9);MACD:2*(DIFF-DEA),COLORSTICK;JC:=CROSS(DIFF,DEA);SC:=CROSSDOWN(DIFF,DEA);MM:VALUEWHEN(SC,REF(SUM(MACD,BARSLAST(JC)+1),1));//金叉开始到死叉MACD和

 

 4、 顶底分型源码

DF:=H>REF(H,1)&&L>REF(L,1)&&REF(H,1)&REF(L,1)//底分

KF:=L>REF(L,1)&&H&REF(L,1)>REF(L,2)&&REF(H,1)>REF(H,2);//顶分型

HH:VALUEWHEN(DF,HHV(H,5));

LL:VALUEWHEN(KF,LLV(L,5

5、多空力量指标源码

 VAR2:=SUM(IF(CLOSE>OPEN,VOL,0),N)/SUM(VOL,N)*100;

VAR3:=100-SUM(IF(CLOSE>OPEN,VOL,0),N)/SUM(VOL,N)*100;

多头力量: VAR2;

空头力量: VAR3;

多空平衡: 50;

 

如果你喜欢本文,麻烦分享关注一下非常感谢!

『正文』

ˇ

简摘:

          价格变化的影响因素繁多,大如全球经济环境,地域冲突,重要政经事件,利率汇率,自然灾害,疾病瘟疫;小如,国内政策,品种供需,流通库存,上下游产业;这么多的因素最终会在价格上反映,如此之多的因素因子单纯想要依靠少许的人力和物力掌握利用是难以完成的庞大工程。依据技术分析的本源思想,最终所有因素都会反应在价格上。量价是技术分析的基础要素,我们这期模型利用量和价来构建交易策略,其中量的利用尤为重要。

持仓量变化(资金流向):

    

    期货市场中,持仓量指的是买入(或卖出)的头寸在未了结平仓前的总和,一般指的是买卖方向未平合约的总和,所以一般都是偶数,通过分析持仓量的变化可以分析市场多空力量的大小、变化以及多空力量更新状况,从而成为与股票投资不同的技术分析指标之一。

  在期货图形技术分析中,成交量和持仓量的相互配合十分重要。正确理解成交量和持仓量变化的关系,可以更准确的把握图形线分析组合,有利于深入了解市场语言。

资金流量计算方法:

  1. 主动性流入:统计C-C[1]大于0于LENTH周期内的持仓量*(波幅)之和;

  2. 主动性流出:统计C-C[1]小于0于LENTH周期内的持仓量*(波幅)之和;

  3. 计算X周期内的主动流入与流出的总和比值,将其百分比化;

其中需要计算周期每一根过往变量值,呈现动态迭代,使用FOR循环处理;

条件逻辑:

  1. 价格上升,同时单位时间内资金主动性净流入;

  2. 价格上升,同时单位时间内资金主动性净流出;

  3. 价格下跌,同时单位时间内资金主动性净流入;

  4. 价格下跌,同时单位时间内资金主动性净流出;

缺点改进:

  1. 单纯的使用量能指标会出现趋势判断错误,假信号频繁,交易效果不佳的情况,因此我们加入了价格趋势的条件因素,资金管理,风险管理;

策略模块构成:

    1.主动性量能计算模块;

    2.价格趋势判断模块;

    3.浮盈回撤止盈模块;

    4.移动吊灯动态止盈止损模块;

测试绩效:

        

策略适用于活跃标的:股指,部分工业,农业,化工,有色等品种;

获得方式:

添加小松鼠领取压缩包,微信:viquant01, 例如:回复"SF09"

或扫描下方二维码

本课程及活动最终解释权归松鼠宽客所有,有任何疑问可咨询客服。

----------------往期精彩内容----------------

量化微小课堂:

看盘指标系列:

精品自动交易策略库:

点击上面免费订阅

问:怎么每天都能免费收到这种好指标呢?

答:只需点上边翔博软件工作室关注,加微信:396950280免费领取!

右侧交易也被称为右半球理论,也就是顺势而为,决对不进行逆势操作,决不预测未来。代表人物江恩,这是一种顺势投机交易方法,最有代表性的话就是:“不怕买高价,不怕卖低点,只要方向没有变,你的顺势单就是对的。”右侧交易法是指在下跌之后卖出股票。就是不要去预测什么时候到顶,也不要预测什么时候会下跌,等待市场给出答案,当趋势出现转折后,再行操作,这叫右侧交易。

右侧交易注意事项:   作为右侧交易:1、跌破5日均线减仓,跌破20日均线斩仓,就是一种典型的右侧交易方式。如是右侧交易者,下降趋势应该已经空仓,耐心地等待着趋势的再度向上。2、作为一种纪律,炒股方法固然重要,但纪律比方法重要上百倍。对于右侧交易者和中线客来说,风险是涨出来的,机会是跌出来的,调整是为了将来更好地上涨。3、可是,很多人跌破了20日均线看30日均线,跌破了30日均线看60日均线,看着某某的文章买入,又在看另外一个某某的文章卖出,这样一来,纪律荡然无存,自我完全丧失,我们的资金也就无法得以保障了。

公式源码:

N:=2.120.10;HLC:=REF(MA((HIGH+LOW+CLOSE)/3,N),1);HV:=EMA(HHV(HIGH,N),3);MA1:=MA(CLOSE,1);WEKS:=EMA(HLC*2-HV,3);预警:CROSS(MA1,WEKS);

通达信电脑版公式导入方法

A:源码导入

1、把要导入的公式(源码)复制下来:方法是用左键先把源码变蓝,之后点右键,点复制;

2、进入主界面,即K线图模式,同时按住CTRL+F,出现公式管理器-->用鼠标左键单击任何一个公式组的名称(选择技术指标公式或者条件选股公式)-->单击其他-->点新建公式-->在出现的公式编辑区的下面的空白处,把刚拷的源码粘贴上,将公式名称复制后粘贴到公式名称栏-->确定-->退出;

3.如有参数的,如:N 1 100 15 之类,则需将这类数据填充到参数表中;

B:文件指标导入

1、先把指标文件复制到桌面(或者你知道的路径);

2、打开通达信,按CTRL+F打开公式管理器点击“导入”按钮;

3、找到桌面上要导入的公式选中”公式“后单击左键,后点击“打开”;

4、把“+”号单击展开,在公式名前的空方框里单击成“勾选”后,在点击下方的“确认”;

5、输入指标名称,回车即可。

特别提示:

选股预警指标编写 ,不同主流行情软件间指标转换。 请联系微信:396950280

一个聚百万原创指标公式圈子

原创价值分享公众号

ID:yungongshi

点击“阅读原文”,进入翔博微商城

阅读推荐

广告位 ID:2 320*120

登录

使用微信帐号直接登录,无需注册